aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorlamp2023-03-05 21:43:24 +0000
committerlamp2023-03-05 21:43:24 +0000
commit42044f09272acdcc30a280e072effe429739c32a (patch)
tree737f34d33e42c6ca6da9f9068a70e176de1736e9 /meson.build
initmain
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..21efd00
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,36 @@
+project(
+ 'wlr-idle-proxy',
+ 'c',
+ version: '1.6',
+ license: 'WTFPL',
+ meson_version: '>=0.50.0',
+ default_options: [
+ 'c_std=c11',
+ ],
+)
+
+cc = meson.get_compiler('c')
+
+dbus = dependency('dbus-1')
+wayland_client = dependency('wayland-client')
+wayland_protos = dependency('wayland-protocols', version: '>=1.21')
+
+subdir('protocol')
+
+src_files = [
+ 'main.c',
+]
+
+executable(
+ 'wlr-idle-proxy',
+ files(src_files),
+ dependencies: [
+ client_protos,
+ dbus,
+ wayland_client,
+ ],
+ install: true,
+)
+
+conf_data = configuration_data()
+conf_data.set('bindir', join_paths(get_option('prefix'), get_option('bindir')))