aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorlamp2023-03-05 21:43:24 +0000
committerlamp2023-03-05 21:43:24 +0000
commit42044f09272acdcc30a280e072effe429739c32a (patch)
tree737f34d33e42c6ca6da9f9068a70e176de1736e9 /protocol/meson.build
initmain
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build46
1 files changed, 46 insertions, 0 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
new file mode 100644
index 0000000..9ac6c07
--- /dev/null
+++ b/protocol/meson.build
@@ -0,0 +1,46 @@
+wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
+
+wayland_scanner = find_program('wayland-scanner', native: true)
+
+# should check wayland_scanner's version, but it is hard to get
+if wayland_client.version().version_compare('>=1.14.91')
+ code_type = 'private-code'
+else
+ code_type = 'code'
+endif
+
+wayland_scanner_code = generator(
+ wayland_scanner,
+ output: '@BASENAME@-protocol.c',
+ arguments: [code_type, '@INPUT@', '@OUTPUT@'],
+)
+
+wayland_scanner_client = generator(
+ wayland_scanner,
+ output: '@BASENAME@-client-protocol.h',
+ arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
+)
+
+client_protocols = [
+ [wl_protocol_dir, 'unstable/idle-inhibit/idle-inhibit-unstable-v1.xml'],
+]
+
+client_protos_src = []
+client_protos_headers = []
+
+foreach p : client_protocols
+ xml = join_paths(p)
+ client_protos_src += wayland_scanner_code.process(xml)
+ client_protos_headers += wayland_scanner_client.process(xml)
+endforeach
+
+lib_client_protos = static_library(
+ 'client_protos',
+ client_protos_src + client_protos_headers,
+ dependencies: [wayland_client]
+) # for the include directory
+
+client_protos = declare_dependency(
+ link_with: lib_client_protos,
+ sources: client_protos_headers,
+)