aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorlamp2023-03-05 21:43:24 +0000
committerlamp2023-03-05 21:43:24 +0000
commit42044f09272acdcc30a280e072effe429739c32a (patch)
tree737f34d33e42c6ca6da9f9068a70e176de1736e9 /shell.nix
initmain
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..0be7253
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,5 @@
+{ pkgs ? import <nixpkgs> {} }:
+ pkgs.mkShell {
+ # nativeBuildInputs is usually what you want -- tools you need to run
+ nativeBuildInputs = with pkgs.buildPackages; [ meson ninja pkg-config wayland wayland-protocols wlroots dbus ];
+}